package requires rustc 1.xx or newer Rust Origin: Application & API OSI layer 7 · Application Last updated 5 Nov 2026

Cargo: error: package `home v0.5.9` cannot be built because it requires rustc 1.81 or newer, while the currently active rustc version is 1.78.0

A dependency's minimum supported Rust version (MSRV) is higher than your toolchain.

Exact message you may see error: package `home v0.5.9` cannot be built because it requires rustc 1.81 or newer, while the currently active rustc version is 1.78.0cannot be built because it requires rustc 1.81 or newerrequires rustc 1.70.0 or newer, while the currently active rustc version isEither upgrade to rustc 1.81 or newer, or useerror: rustc 1.70.0 is not supported by the following package
Seen on: Rust

Meaning

Update Rust (rustup update), or pin an older compatible crate version (cargo update -p home --precise 0.5.5), or enable the MSRV-aware resolver (resolver.incompatible-rust-versions = "fallback", Cargo 1.84+). Set rust-version in your own Cargo.toml to document yours.

Common causes

  • Toolchain older than the crate's rust-version
  • Fresh lock resolving latest versions
  • CI/Docker with an old Rust image
  • Distro-packaged old rustc
  • Many crates raising MSRV

⚡ Quick fix

  1. rustup update stable
  2. cargo update -p CRATE --precise OLDER
  3. Use MSRV-aware resolver or cargo-msrv

Detailed fix by platform

Rust

  1. rustc --version; cargo update -p home --precise 0.5.5

How to diagnose

  1. Rustc — Active version?
  2. Required — rust-version?
  3. Pin — Older crate?

🔧 Still not fixed?

Many errors look alike. If the steps above didn’t solve it, one of these is probably what you’re facing:

Where this error sits

Origin: Application & API. Errors that are often confused with or caused by this one (click to open):

Blocking waiting for file lock on package cache / build directory — Cargo: Blocking waiting for file lock on package cache / on build directory (Rust)Blocking waiting for …cargo: failed to get from registry (spurious network error) — Cargo: warning: spurious network error (2 tries remaining): [35] SSL connect error / error: failed to download from `https://index.crates.io/...` (Rust)cargo: failed to get …cargo: failed to select a version for the requirement — Cargo: error: failed to select a version for the requirement `serde = "^2.0"` — candidate versions found which didn't match: 1.0.197 (Rust)cargo: failed to sele…E0004: non-exhaustive patterns — Rust: error[E0004]: non-exhaustive patterns: `None` not covered (Rust)E0004: non-exhaustive…E0658: use of unstable library feature — Rust: error[E0658]: use of unstable library feature `let_chains` / `#![feature]` may not be used on the stable release channel (Rust)E0658: use of unstabl…failed to run custom build command for openssl-sys — Cargo: error: failed to run custom build command for `openssl-sys v0.9.99` — Could not find directory of OpenSSL installation / pkg-config not found (Rust)failed to run custom …feature edition2024 is required / Cargo.lock version too new — Cargo: error: failed to parse manifest — feature `edition2024` is required / lock file version 4 requires `-Znext-lockfile-bump` (Rust)feature edition2024 i…package r…

Explore the map of this error Full error map →

🧠 Still stuck? Analyze your error

Paste the full message, response headers or stack trace — we'll detect the platform and point to the most likely cause.

💬 What worked for others

No tips yet — did something else fix this for you?

Share what worked for you

Tips are checked by an editor before they appear. Links are removed.