# Terraform: Error: Unsupported Terraform Core version — This configuration does not support Terraform version 1.5.7

**Code:** `Unsupported Terraform Core version` · **Category:** Terraform · **Seen on:** Terraform

The installed Terraform CLI doesn't satisfy `required_version` in the configuration (or a module).

## Meaning

Install a matching version (`tfenv install 1.9.5`, `asdf`, or download), or adjust `required_version` if safe. Modules can also set constraints — the message names the file. Teams should pin one version via `.terraform-version`/CI.

## Common causes

- CLI older/newer than `required_version`
- Module requiring a different version
- CI image with another Terraform
- Multiple Terraform binaries on PATH
- State written by a newer version

## Quick fix

1. `tfenv install && tfenv use` per `.terraform-version`
2. Update `required_version = ">= 1.5, < 2.0"` consistently
3. Align CI and local versions

## Detailed fix by platform

### Terraform

1. `terraform version && grep -R required_version --include=*.tf .`

## How to diagnose

1. **Constraint** — Where?
2. **CLI** — Version?
3. **Pin** — tfenv/asdf?

---
Source: [WhatIsMyError](https://whatismyerror.com/errors/terraform/unsupported-terraform-core-version)
